Image Target Formats

There are certain advantages to using one “re-rendering” file format over the others, depending upon your application.

JPEG is a lossy format which means the cost of JPEG’s greater compression levels is some blurriness in the image. PNG on the other hand, will always display the image without any loss in quality. However, on some image JPEG can produces much smaller files.

The level of compression a format will provide depends greatly on the contents of the image. Even the same image, when rotated may produce different results. Although there are rules of thumb, if size is critical, always test the image with all formats to see which is best.

The table below compares the various file formats:

Format Description
PNG The preferred format and will produce the highest quality graphic images with full color..
PNG 8 This is an 8-bits-per-pixel PNG and supports single color transparency. The files will generally be smaller than full color PNG, but the colors will be fewer (256 maximum). SiteSpinner® Pro chooses the optimal set of colors for each PNG 8 object when your project is previewed or published, so it often looks as good as full-color PNG, but not always. For example, gradients or photographs may look banded.

PNG 32

This is a 32-bits-per-pixel PNG. It supports full color and transparency, but is not supported in older browsers.

GIF

GIF should pretty much work like PNG8. Some very old browsers will support GIF but not PNG8. PNG8 can use true or simulated transparency but GIF always uses true. They use different compression algorithms, so the size may be different depending on the contents of the image.

Re-rendered GIF images do not support animation.

JPG Best for photographic images. Will export the geometry using full color but without transparency. This format is preferred for images such as photographs that have many shades of color blending into one another (as opposed to those that have large sections with solid colors which are better suited to PNG).

Use the Size slider on the Project Options dialog box to set the compression level. A lower number will produce a smaller file size, but a lower-quality image. Conversely, a higher number will produce a better looking image, but the file size will be bigger. The default setting is 75. A quality setting higher than 95 is not recommended, as it will result in a much larger file with little discernable difference in quality. Even raising the value above 75 will increase the file’s size without giving you dramatically better images. If you find the results in quality over 90 are not adequate, PNG may be a better format to use.

BMP Uncompressed bitmap format. Will produce a full-color BMP image of the vector geometry. BMP is not recommended for use on web pages due to its extremely large file size and the fact that many browsers do not support it. Exporting to a BMP format may be useful if you wish to convert the image to another format using a third-party image program
 
Setting Rendering File Format for All Objects
  1. Select Options>Project Options.

    The Project Options dialog box will open.

  2. In the Default Image Format section, click to select the radio button corresponding to your desired output file format for re-rendered objects. Choose from PNG, PNG 8, PNG 32, GIF, JPG, or BMP

    OR

    If you want the re-rendered file format to be the same as the original file format as it was imported into SiteSpinner® Pro (image objects only), click to checkmark the Use Picture’s Format option box.

If an image is not re-rendered, the original image file will be used.

  1. Click the Apply to All Objects button.

    A message box will appear asking you to confirm your choice. This will apply the settings to all objects in the current project. If you don’t click this button the current objects will be left as they are. Either way, the format settings you choose here will be applied to all new objects.

  2. Click Yes. The message box will close.
  3. Click OK. The Project Options dialog box closes, and all rendered objects in the project will be re-rendered in the selected file format.

The setting will not affect existing objects. To apply settings to existing objects in the project click the Apply to all Images button.

You may override the global project setting for individual objects.

Setting Rendering File Format for an Object
  1. In the Work Window, click to select a rendered object whose output file format you want to set individually.

Rendered objects include rectangle, ellipse, polygon, curve, title, and image objects.

  1. Press the ALT+G keyboard shortcut

    OR

    Right-click the object, and then select Edit Geometry

    OR

    Click the Geometry Editor button: in the Object Bar

    OR

    Select Object>Geometry Editor.

    The Geometry Editor dialog box will open.

  2. Click the Options Tab.
  3. Click to un-checkmark the Use Image’s Format option box.

    Options in the Rendering File Format section will become available.

  4. In the Rendering File Format section, click to select the radio button corresponding to your desired output file format for re-rendered objects. Choose from PNG, PNG 8, PNG 32, GIF, JPG, or BMP.
  5. If you have selected the JPEG format, click and drag the Quality/Size slider either right or left

    OR

    Enter a value in the box.

    A lower setting will reduce the image quality but minimize the file size. A higher setting improves image quality but increases file size.

  6. If you have selected either the PNG, JPG, or BMP file format, click to checkmark the Render Background option box.
  7. Click OK. The individual object will be re-rendered when published using the selected output file format. This setting will supersede the global re-rendered file format.

 Previous Next