The Text Editor can be used to create formatted text, rendered titles, or to add raw code for HTML, SVG and Scripts. This is a Text Object. It uses a word processor to create HTML formatted text.

A new Text Object can be created by selecting the green "
Text" button on the components toolbar to the left. An existing Text Object can be edited by double clicking the Object.


You should now be in the Text Editor. As you will note it provides many of the formatting features you will find in most word processors. You can select any portion of this text and change it. Try selecting the red text above to change its color, underline, bold, font style, font size or any other attribute that is available. The operations and dialogs to do this are located on the menu and toolbars above. You can then select the OK button at the bottom of this editor to save your changes and return to the work window and then select the Preview button >> to see the modified text in a HTML page.

When you are finished previewing, close the Browser to return to the Work Window then double click this text Object again to return to this editor.

Most people are familiar with word processing so you can try playing with the various operations yourself. If you do need help select the Help Menu or Question mark to get more information on the specific operations that are available.

The text editor however, is not designed to be a standard word processor. Its primary purpose is to create formatted text for export to HTML, SVG and other formats that will be supported in the future. The editor consequently may not include some typical word processing operations that are difficult or impossible to export to these supported formats. On the other hand, it does include several operations and features that are not common to most word processors. Please take a few moments to familiarize yourself with these advanced operations.

1. The Hyperlink Editor

The editor includes advanced support for hyperlink operations. The following blue underlined text is an active link to the web site. If you are connected to the Internet you can left click on this link to connect to our home page. Try it now.

The editor will also automatically create a link if you type a recognizable URL. If you have a web site select a space in this text and then enter the URL. After you enter a trailing blank, the link will automatically be created. Try it now then left click the active link. Exit this Text Editor and select the Preview button again to confirm that the link has been created in the web page. Close the browse then double click this text Object to re-enter the Text Editor.

The hyperlink editor provides more features than this. You can create a link for any text by selecting it then select the Hyperlink button above. Select this uppercase BOLDED TEXT then open the link editor to assign a link to the text. It is the button with a picture of the Earth and a link below (you can also use the Insert URL menu).

Assuming you have figured out how to exit the Link Dialog you will have discovered that the Link Dialog provides many advanced features. These include the ability to create several different types of links including: Mail links, FTP links, the standard http link to a web site and more. A special link that you should note is the Page Link. This will display a list of pages in your current project that you can create a link to. The main advantage with a page link is that it will keep track of the name of the page. If for example, you create a lot of links to a page in the project and then decide at a later time to change the name of the page or to delete it, the links will automatically be updated the next time you publish your project. You should consequently create Page-Links to pages within the current project to ensure that your links remain valid.

Other features within the Link Editor include the ability to assign a Title, to Bookmark the link, to set it to open in its own window and to assign it a unique color (the default link colors are assigned in the Page Editor). You can also Import and Export links for sharing with other applications.

2. Expanded Hyperlink View

A unique feature of the text editor is its ability to expand all hyper-links to their HTML format. To do this, select the Expanded Hyperlinks button on the top toolbar to the right with the magnifying glass or from the Options menu. All links within this document will be displayed as full HTML anchors. Try it now. This link should now be displayed in it expanded format.
You can modify the elements of the link directly within the editor. This is especially convenient if you wish to make global edit changes or if you wish to examine the links without having to continuously enter the link editor. But be careful not to invalidate the links by changing the HTML tags. The editor expects to find the links in this format. When exporting to SVG or other formats that support links, these HTML formatted links will automatically be converted to their equivalent XML format.

3. Options and Filters

The editor includes the ability to set various options and to filter special characters that may otherwise cause problems when converted to HTML or other formats. You can customize these Options and Filters by opening the Options Menu - Options and Filters dialog. Some of the Options that are available include:
 Some of the filters that are available include:
4. Spell Checker

The Text Editor includes the Wintertree Spell checker. The spell checker can be set to automatically highlight mispeld words. Right click on the word to find alternative spelling. Right click on the misspelt word above to find the correct spelling. You can check all words in the editor by selecting the Tools menu - Spell Check command. The Options menu also includes a Spell Preference dialog and a Dictionary so that you can customize your spelling preferences.

5. Importing Text

Text is formatted using the Rich Text (.rtf) standard. This format is supported by the majority of word processors. Formatted text can consequently be transferred from most word processors using Copy and Paste. Select the text to by transferred from the word processor, select Copy (Ctrl-C), select the location in the text editor to paste the selected text and Paste (Ctrl-V).

You can also import text from a .rtf file. In the word processor select Save As, Select the Rich Text (.rtf) file type and save. In the text editor select the File Open command and select the Rich Text file you have saved.

Rich text is an extensive format that includes some formatting that is not supported by the text editor or by the export formats. These include embedded pictures, columns and more. The editor will attempt to ignore these unsupported formats if they are encountered in the Rich Text formatting stream.

6. Adjusting the Bounding Box.

When you exit the editor, a bounding box will be created that calculates the height of the Text Object to fit all the text according to the Objects current width. The current width of the text Object is displayed on the ruler at the top of the Text Editor. You can use the slider to change the width of the text Object within the editor. Try it now.

A Text Object like any other Object, can be positioned within the work window using your mouse. Unlike Titles, Text Objects cannot be rotated or scaled.  If you adjust the size of the bounding box however, the text will wrap to fit the new width.

When you are finished reading this exit the editor by selecting the Cancel button below and then use your mouse to move the text Object and change the size of the bounding box. Preview to see your changes.

For more help with the Text Editor, see Help > Text Editor. You can also visit the Working with Text FAQ .
Virtual Mechanics
< tutorials home
TM & © 1998 - 2004, Virtual Mechanics, all rights reserved.