New Objects

You can add an object to a page using two different methods:

You can add certain object types to your page using other methods. For more information, see Object Types.

SiteSpinner® Pro will respond to your new object command in different ways, depending upon the type of object you have selected.

Adding a Rectangle Object

1. With a page open in the Work Window, click the Rectangle button:  in the Tools Bar

OR

Select Object>Shapes>Rectangle.

The mouse pointer turns into a crosshairs cursor in the Work Window and displays the current X and Y position coordinates on the page.

2. Move the mouse pointer to the position on the page where you want to place the rectangle.

3. Click and drag the mouse in any direction on the page to draw the rectangle.

4. When you are finished, release the mouse button. The rectangle object is added to the page and registered as an object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

Drawing a Square

Use the following procedure to add a rectangle object with square dimensions:

1. With a page open in the Work Window, click the Rectangle button:  in the Tools Bar.

The mouse pointer turns into a crosshairs cursor in the Work Window and displays the current X and Y position coordinates on the page.

2. Click once on the page where you want to place the square.

The Set Size dialog box will open. For more information, see Set Size Dialog Box.

3. Accept the default Width and Height settings of 100, and proceed to step 4

OR

Edit the Width and Height settings, if desired, keeping the new settings identical.

4. Click OK. The dialog box will close. The square is added to the page and registered as a rectangle object in the project file.

5. To scale the square larger or smaller while constraining its proportions, press the CTRL key while clicking and dragging one of the square’s corner control points.

You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

Adding a Straight Line

Use the following procedure to add a line segment as a shape object:

1. With a page open in the Work Window, select Object>Shapes>Horizontal Line to draw a horizontal line object

OR

Select Object>Shapes>Vertical Line to draw a vertical line object.

A temporary line object 100 pixels long appears in the Work Window adjacent to the mouse pointer. The mouse pointer turns into a crosshairs cursor in the Work Window and displays the current X and Y position coordinates on the page.

2. Move the mouse pointer to the position on the page where you want to place the line segment.

3. Click and release the mouse.

The line segment is added to the page and registered as a polygon object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

Adding a Triangle Object

Use the following procedure to add a triangle as a shape object:

1. With a page open in the Work Window, select Object>Shapes>Triangle.

A temporary triangle object appears in the Work Window adjacent to the mouse pointer. The mouse pointer turns into a crosshairs cursor in the Work Window and displays the current X and Y position coordinates on the page.

2. Move the mouse pointer to the position on the page where you want to place the triangle.

3. Click and release the mouse.

The triangle is added to the page and registered as a polygon object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

Adding a Star Object

Use the following procedure to add a star as a shape object:

1. With a page open in the Work Window, select Object>Shapes>Star.

A temporary five-pointed star object appears in the Work Window adjacent to the mouse pointer. The mouse pointer turns into a crosshairs cursor in the Work Window and displays the current X and Y position coordinates on the page.

2. Move the mouse pointer to the position on the page where you want to place the star.

3. Click and release the mouse.

The star is added to the page and registered as a polygon object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

Adding an Ellipse Object

1. With a page open in the Work Window, click the Ellipse button:  in the Tools Bar

OR

Select Object>Shapes>Ellipse.

The mouse pointer turns into a crosshairs cursor in the Work Window and displays the current X and Y position coordinates on the page.

2. Move the mouse pointer to the position on the page where you want to place the ellipse.

3. Click and drag the mouse in any direction on the page to draw the ellipse.

4. When you are finished, release the mouse button. The ellipse object is added to the page and registered as an object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

Drawing a Circle

Use the following procedure to add an ellipse object with circular dimensions:

1. With a page open in the Work Window, click the Ellipse button:  in the Tools Bar.

The mouse pointer turns into a crosshairs cursor in the Work Window and displays the current X and Y position coordinates on the page.

2. Click once on the page where you want to place the circle.

The Set Size dialog box will open. For more information, see Set Size Dialog Box.

3. Accept the default Width and Height settings of 100, and proceed to step 4

OR

Edit the Width and Height settings, if desired, keeping the new settings identical.

4. Click OK. The dialog box will close. The circle is added to the page and registered as an ellipse object in the project file.

5. To scale the circle larger or smaller while constraining its proportions, press the CTRL key while clicking and dragging one of the object’s corner control points.

You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

Adding a Polygon Object

1. With a page open in the Work Window, click the Polygon button:  in the Tools Bar

OR

Select Object>Shapes>Polygon.

The mouse pointer turns into a crosshairs cursor in the Work Window and displays the current X and Y position coordinates on the page.

2. Move the mouse pointer to the position on the page where you want to place the polygon.

3. To freehand draw while allowing SiteSpinner® Pro to determine the number of editable points along each side of the polygon, click and drag the mouse smoothly in any direction on the page (For more information, see Guide/Display Options Dialog Box.)

OR

To draw while placing one editable point in each corner of the polygon, click and release the mouse at the beginning point, move your cursor in any direction on the page, click and release your mouse again to add another point, and move your cursor in another direction on the page. Repeat these actions to continue drawing the polygon.

4. To complete the drawing as a closed polygon, click the first point  

OR

To complete the drawing as an open polygon, double-click the mouse.

The polygon object is added to the page and registered as an object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

Adding a Curve or Path Object

1. With a page open in the Work Window, click the Path Object button:  in the Tools Bar

OR

Select Object --> Shapes --> Spline   or   Object --> Shapes --> Path Object in the main menu.

See Curve Objects and the Tutorials for more  information.

Adding a Title Object

1. With a page open in the Work Window, click the Title button:  in the Tools Bar

OR

Select Object>Title.

The Title Editor dialog box will open. For more information, see Title Editor Dialog Box.

2. Enter a title in the Title Editor window.

3. Choose Font, Style, Size, Color, and Alignment options for the title.

4. If you want any jagged edges of the title object to be smoothed, click to checkmark the Anti-Alias option box.

5. When you are finished, click OK. The dialog box will close. The title object is added to the page and registered as an object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

Adding an Image Object

1. With a page open in the Work Window, click the Picture button:  in the Tools Bar

OR

Select Object>Image.

The Open dialog box will appear. For more information, see Open Dialog Box.

2. Browse for the image file on your system or network (in .png, .png, .jpg, or .gif format) that you want to add to the page.

3. With the name of the desired image file displaying in the File name field, click the Open button. The image object is added to the page and registered as an object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

You can select multiple images files in the File Open dialog and open them all at once. Hold SHIFT to select a range or CTRL to select individual files  

You may also add an image object to a page by pasting an image that you have cut or copied from another application.

You may also add an image by clicking to select an image file in Windows® Explorer® or from a web page, and then dragging it onto the page in the Work Window. If the image includes a hyperlink, the image will not drag/drop (the link will), so you must right-click and select Copy then paste the image. When you save the project file, you will be prompted to save the pasted image separately to a specified location on your system.

Adding a Code Object

1. With a page open in the Work Window, click the Code button:  in the Tools Bar

OR

Select Object>Code.

The Text Editor dialog box will open in Code Edit Mode. For more information, see Text Editor Dialog Box (Code Edit Mode).

Enter code in the Code Editor window

OR

Select File>Open File to open a text or HTML file in the Title Editor

OR

Paste code copied from another application.

2. Click the No CSS toolbar button to strip the code object of any positioning tags in the page code (HTML or SVG), if desired. For more information, see No CSS Positioning.

3. When you are finished, click the Save and Close button. The code object is added to the page and registered as an object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

Adding a Text Object

1. With a page open in the Work Window, click the Text button:  in the Tools Bar

OR

Press the CTRL+T keyboard shortcut

OR

Select Object>Text.

The Text Editor dialog box will open in Text Edit Mode. For more information, see Text Editor Dialog Box (Text Edit Mode).

2. Enter text in the Text Editor window

OR

Select File>Open File to open a text document in the Title Editor

OR

Paste text copied from another application.

3. Choose Font, Style, Size, and Color options for the text.

4. Apply a hyperlink to selected text using the Link Editor dialog box, if desired. For more information, see Hyperlinking.

5. Add an Auto Scroll bar to help your users view a lengthy text passage, if desired. For more information, see Auto Scroll.

6. Check your text entry for spelling by selecting Tools>Spelling Checker, if desired. For more information, see Check Spelling Dialog Box.

7. When you are finished, click the Save and Close button. The text object is added to the page and registered as an object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

You may also paste text copied from another application directly onto the page in the Work Window, thus creating a text object. The text will lose any formatting it had in the original application. You may reformat the text in the Text Editor. For more information, see “Text Objects.”

When you import text that contains tables, the Text Editor will strip the text out of the tables and remove the tables.

Adding a File or Media Object

1. With a page open in the Work Window, click the Embed File or Media button:  in the Tools Bar

OR

Select Object>Embed File or Media.

The Embed File or Media dialog box will open. For more information, see Embed File or Media dialog box.

2. From the Format drop-down list, select the type of file or media object you want to add to the page.

3. Click the Filepath button.

The Open dialog box will appear.

4. Browse for the file or media object on your system or network that you want to add to the page.

5. If you are adding a HTML IFrame or SVG object, click the Page List button and select from the drop-down menu the project page you wish to add, if desired.

6. Add a Codebase and Name and Value parameters, if desired.

7. If you are adding a media object, select the Auto-Start, Continuous Play, or Visible Control option box, if desired.

8. When you are finished, click OK. The object is added to the page and registered as an object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.

Adding a Table Object

1. Select Object --> Table.

The mouse pointer turns into a crosshairs-and-object cursor in the Work Window and displays the current X and Y position coordinates of the upper left corner of the table.

2. Move the mouse pointer to the position on the page where you want to place the table.

3. When you are finished, release the mouse button. The table object is added to the page and registered as an object in the project file. You may rename, move, transform, or edit the object. For more information, see Object Names, Move Object, Transform Object, and Editing Objects.